gluarequire2: a4.io/gluarequire2 Index | Files

package gluarequire2

import "a4.io/gluarequire2"

Index

Package Files

github.go gluarequire2.go

func NewRequire2Module Uses

func NewRequire2Module(requireSetuper RequireSetuper) *require2

type RequireFromGitHub Uses

type RequireFromGitHub struct {
    // contains filtered or unexported fields
}

func NewRequireFromGitHub Uses

func NewRequireFromGitHub(conf *RequireFromGitHubConf) *RequireFromGitHub

func (*RequireFromGitHub) Setup Uses

func (rfgh *RequireFromGitHub) Setup(L *lua.LState, name string) (string, error)

type RequireFromGitHubConf Uses

type RequireFromGitHubConf struct {
    Path string
}

type RequireSetuper Uses

type RequireSetuper interface {
    Setup(L *lua.LState, name string) (newName string, err error)
}

Package gluarequire2 imports 8 packages (graph) and is imported by 2 packages. Updated 2020-03-07. Refresh now. Tools for package owners.