mikrotik-hosts-parser

module
v4.6.0 Latest Latest
Warning

This package is not in the latest version of its module.

Go to latest
Published: Mar 16, 2024 License: MIT

README

Logo

MikroTik hosts parser

Release version Build Status Coverage Image size License

This application provides HTTP server, that can generate script for RouterOS-based routers for blocking "AD" hosts using 3rd party host-lists (available by HTTP):

## Limit: 5000
## Cache lifetime: 30m0s
## Format: routeros
## Redirect to: 127.0.0.1
## Sources list:
##  - <https://adaway.org/hosts.txt>
##  - <https://www.malwaredomainlist.com/hostslist/hosts.txt>
## Excluded hosts:
##  - broadcasthost
##  - ip6-allhosts
##  - ip6-allnodes
##  - ip6-allrouters
## Cache HIT for <https://adaway.org/hosts.txt> (expires after 25m55s)
## Cache miss for <https://www.malwaredomainlist.com/hostslist/hosts.txt>

/ip dns static
add address=127.0.0.1 comment="ADBlock" disabled=no name="1-1ads.com"
add address=127.0.0.1 comment="ADBlock" disabled=no name="101com.com"
add address=127.0.0.1 comment="ADBlock" disabled=no name="101order.com"
add address=127.0.0.1 comment="ADBlock" disabled=no name="123freeavatars.com"

# ...

Hosts file format (example):

# Any comments
127.0.0.1   1-1ads.com
127.0.0.1   101com.com 101order.com
0.0.0.0     123freeavatars.com

All what you need is:

  • Start current application HTTP server
  • Make an HTTP request to the script generator endpoint /script/source?sources_urls=... with all required parameters (like records limit, hosts file URLs, exclusion list and others)
  • Generated script source execute on your RouterOS-based hardware

More information can be found here.

Previous version (PHP) can be found in php-version branch.

Installing

Download latest binary file for your os/arch from releases page or use our docker image (ghcr.io). Also you may need in configuration file ./configs/config.yml and ./web directory content for web UI access.

Usage

This application supports next sub-commands:

Sub-command Description
serve Start HTTP server
healthcheck Health checker for the HTTP server (use case - docker healthcheck) (hidden in CLI help)
version Display application version

And global flags:

Flag Description
--verbose, -v Verbose output
--debug Debug output
--log-json Logs in JSON format
HTTP server starting

serve sub-command allows to use next flags:

Flag Description Default value Environment variable
--listen, -l IP address to listen on 0.0.0.0 (all interfaces) LISTEN_ADDR
--port, -p TCP port number 8080 LISTEN_PORT
--resources-dir, -r Path to the directory with public assets ./web RESOURCES_DIR
--config, -c Config file path ./configs/config.yml CONFIG_PATH
--caching-engine Caching engine (memory or redis) memory CACHING_ENGINE
--cache-ttl Cached entries lifetime (examples: 50s, 1h30m) 30m CACHE_TTL
--redis-dsn Redis server DSN, required only if redis caching engine is enabled redis://127.0.0.1:6379/0 REDIS_DSN

Environment variables have higher priority then flag values.

Server starting command example:

$ ./mikrotik-hosts-parser serve \
    --config ./configs/config.yml \
    --listen 0.0.0.0 \
    --port 8080 \
    --resources-dir ./web

This command will start HTTP server using configuration from ./configs/config.yml on TCP port 8080 and use directory ./web for serving static files. Configuration file well-documented, so, feel free to change any settings on your choice!

Configuration file allows you to use environment variables with default values (used library)!

After that you can navigate your browser to http://127.0.0.1:8080/ and you will see something like that:

screenshot

Special endpoint /script/source?sources_urls=... generates RouterOS-based script using passed http-get parameters (watch examples on index page).

Using docker

image stats

All supported image tags can be found here and here.

Just execute in your terminal:

$ docker run --rm -p 8080:8080/tcp tarampampam/mikrotik-hosts-parser:X.X.X

Where X.X.X is image tag (application version).

Demo

I can't guarantee that this links will available forever, but you can use this application by the following links:

Testing

For application testing and building we use built-in golang testing feature and docker-ce + docker-compose as develop environment. So, just write into your terminal after repository cloning:

$ make test

Or build the binary file:

$ make build

Releasing

New versions publishing is very simple - just make required changes in this repository, update changelog file and "publish" new release using repo releases page.

Binary files and docker images will be build and published automatically.

New release will overwrite the latest docker image tag in both registers.

Changes log

Release date Commits since latest release

Changes log can be found here.

Support

Issues Issues

If you will find any package errors, please, make an issue in current repository.

License

This is open-sourced software licensed under the MIT License.

Directories

Path Synopsis
cmd
mikrotik-hosts-parser
Main CLI application entrypoint.
Main CLI application entrypoint.
internal
pkg/breaker
Package breaker provides OSSignals struct for OS signals handling (with context).
Package breaker provides OSSignals struct for OS signals handling (with context).
pkg/cache
Package cache contains different byte-cache implementations.
Package cache contains different byte-cache implementations.
pkg/checkers
Package checkers contains different checkers.
Package checkers contains different checkers.
pkg/cli
Package cli contains CLI command handlers.
Package cli contains CLI command handlers.
pkg/cli/healthcheck
Package healthcheck contains CLI `healthcheck` command implementation.
Package healthcheck contains CLI `healthcheck` command implementation.
pkg/cli/serve
Package serve contains CLI `serve` command implementation.
Package serve contains CLI `serve` command implementation.
pkg/cli/version
Package version contains CLI `version` command implementation.
Package version contains CLI `version` command implementation.
pkg/config
Package config contains application configuration struct with the most useful functions.
Package config contains application configuration struct with the most useful functions.
pkg/env
Package env contains all about environment variables, that can be used by current application.
Package env contains all about environment variables, that can be used by current application.
pkg/http
Package http contains HTTP server and all required stuff for HTTP server working.
Package http contains HTTP server and all required stuff for HTTP server working.
pkg/http/fileserver
Package fileserver contains static files server implementation.
Package fileserver contains static files server implementation.
pkg/http/handlers/api/settings
Package settings contains API handler for application settings getting.
Package settings contains API handler for application settings getting.
pkg/http/handlers/api/version
Package version contains version API handler.
Package version contains version API handler.
pkg/http/handlers/generate
Package generate contains RouterOS script generation handler.
Package generate contains RouterOS script generation handler.
pkg/http/handlers/healthz
Package healthz contains healthcheck handler.
Package healthz contains healthcheck handler.
pkg/http/handlers/metrics
Package metrics contains HTTP handler for application metrics (prometheus format) generation.
Package metrics contains HTTP handler for application metrics (prometheus format) generation.
pkg/http/middlewares/logreq
Package logreq contains middleware for HTTP requests logging using "zap" package.
Package logreq contains middleware for HTTP requests logging using "zap" package.
pkg/http/middlewares/nocache
Package nocache contains middleware for HTTP response caching disabling.
Package nocache contains middleware for HTTP response caching disabling.
pkg/http/middlewares/panic
Package panic contains middleware for panics (inside HTTP handlers) logging using "zap" package.
Package panic contains middleware for panics (inside HTTP handlers) logging using "zap" package.
pkg/logger
Package logger contains functions for a working with application logging.
Package logger contains functions for a working with application logging.
pkg/metrics
Package metrics contains custom prometheus metrics and registry factories.
Package metrics contains custom prometheus metrics and registry factories.
pkg/version
Package version is used as a place, where application version defined.
Package version is used as a place, where application version defined.
pkg
hostsfile
Package hostsfile contains basic functions for the hosts file working.
Package hostsfile contains basic functions for the hosts file working.
mikrotik
Package mikrotik contains specific for RouterOS structs and functions.
Package mikrotik contains specific for RouterOS structs and functions.

Jump to

Keyboard shortcuts

? : This menu
/ : Search site
f or F : Jump to
y or Y : Canonical URL