changelog

package
v0.16.0 Latest Latest
Warning

This package is not in the latest version of its module.

Go to latest
Published: Oct 31, 2023 License: BSD-3-Clause, MIT Imports: 7 Imported by: 3

Documentation

Overview

Parse the Debian changelog format.

Index

Constants

This section is empty.

Variables

This section is empty.

Functions

This section is empty.

Types

type ChangelogEntries

type ChangelogEntries []ChangelogEntry

func Parse

func Parse(reader io.Reader) (ChangelogEntries, error)

func ParseFile

func ParseFile(path string) (ChangelogEntries, error)

type ChangelogEntry

type ChangelogEntry struct {
	Source    string
	Version   version.Version
	Target    string
	Arguments map[string]string
	Changelog string
	ChangedBy string
	When      time.Time
}

A ChangelogEntry is the encapsulation for each entry for a given version in a series of uploads.

func ParseFileOne

func ParseFileOne(path string) (*ChangelogEntry, error)

func ParseOne

func ParseOne(reader *bufio.Reader) (*ChangelogEntry, error)

Jump to

Keyboard shortcuts

? : This menu
/ : Search site
f or F : Jump to
y or Y : Canonical URL